[Buildbot-devel] GitPoller fixes in 0.8.3p1

Axel Hecht l10n.moz at googlemail.com
Fri Jan 7 14:54:53 UTC 2011

I'm testing fcfc8840c1bef89da8d337a2c509247a86a62d5a, fwiw, but I think I
nailed it down. Verified against master, too,

subprocess.check_call uses the PATH environment to look for git, while I
suspect that
and thus doesn't find my git binary that's in a somewhat off
location on my mac, /usr/local/git/bin/git.

No idea how to fix that. But once I explicitly specified a gitbin to
GitPoller, it worked.

The error message that I got for that was much more revealing on master than
on, fwiw.


2011/1/7 Dustin J. Mitchell <dustin at v.igoro.us>

> On Thu, Jan 6, 2011 at 9:14 PM, Axel Hecht <l10n.moz at googlemail.com>
> wrote:
> > I still get errors on startup, I guess it's mid-air or so. master has
> >
> https://github.com/buildbot/buildbot/commit/9dd0ece91c671c7995f6a0ab818e5886463e5775
> > and its parent, too, didn't check that myself, though. Not trusting
> master
> > itself too much tonight.
> I'm not sure what all of that means - "mid-air or so"? Master has two
> commits?  What didn't you check?  And why don't you trust master?  And
> which master is that - your buildmaster, or the master branch of
> buildbot?  Sorry if I'm being dense.
> Also, the rev I'd like to see tested (see OP) is 15fbae9, or
>    http://buildbot.net/tmp/buildbot-0.8.3-2-g15fbae9.tar.gz
> The revision you mentioned is not on the 0.8.3 branch.  Are you checking
> master?
> Dustin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://buildbot.net/pipermail/devel/attachments/20110107/df93a970/attachment.html>

More information about the devel mailing list