[Buildbot-devel] Splitting slave from master

Dustin J. Mitchell dustin at zmanda.com
Mon Jun 7 15:34:29 UTC 2010

On Mon, Jun 7, 2010 at 7:28 AM, Greg Ward <greg at gerg.ca> wrote:
> Makes sense.  I guess it's too late to suggest that "buildslave"
> should be called "buildbot-slave" or "buildbot.slave" or
> "buildbot_slave" or something similar?  You can still use that
> terminology in your source tarball, and that will spill out to
> RPM/dpkg/port names, which is possibly more important.  (IMHO "apt-get
> install buildbot-slave" makes much more sense than "apt-get install
> buildslave".
> It just seems to me that the term "buildslave" is a bit vague and does
> not make clear that this code is part of BuildBot.

Do you mean the distribution name, or the python package name?  We
could certainly change the distribution name..


Open Source Storage Engineer

More information about the devel mailing list