[Buildbot-devel] Splitting slave from master

Greg Ward greg at gerg.ca
Mon Jun 7 12:28:11 UTC 2010

On Sat, Jun 5, 2010 at 3:33 PM, Dustin J. Mitchell <dustin at zmanda.com> wrote:
> I shouldn't have used the term "package" - what I'd like is to have
> two separate installable, um, "things" (eggs in setuptools' terms):

Ah yes.  We dealt with that ambiguity in distutils by calling them
"distributions" -- it's an awkward term, but nobody had any better

> easy_install buildslave # <--- has very few requirements other than Twisted
> easy_install buildbot # <--- has lots of requirements

Makes sense.  I guess it's too late to suggest that "buildslave"
should be called "buildbot-slave" or "buildbot.slave" or
"buildbot_slave" or something similar?  You can still use that
terminology in your source tarball, and that will spill out to
RPM/dpkg/port names, which is possibly more important.  (IMHO "apt-get
install buildbot-slave" makes much more sense than "apt-get install

It just seems to me that the term "buildslave" is a bit vague and does
not make clear that this code is part of BuildBot.


More information about the devel mailing list