[Buildbot-devel] FileDownload step never finishes

Oliver Rusterholz o.rusterholz at bluewin.ch
Thu Nov 22 08:31:43 UTC 2007

John Bäckstrand <sandos at ...> writes:

> Brian Warner wrote:
> >> Does anyone know what the problem is likely to be?
> > 
> > Not offhand, but I know that FileDownload/upload has a control-flow problem
> > when the number of segments it sends gets large, something is screwed up that
> > causes each segment to get a new stack frame, until you can hit
> > "RuntimeError: maximum recusion depth exceeded" exceptions.
> I tried using a FileUpload a week or two ago, but the step never 
> completed. File was 25+MB. I then decided that I should probably not use 
> buildbot for "managing" artefacts anyway, so I just gave up on FileUpload.

I had the same problem while uploading files bigger than 100MB but solved it
with specifying "blocksize=640*1024" in the buildstep. It has to be exactly
640*1024, everything else didn't work.


More information about the devel mailing list