[Buildbot-devel] Git changes won't trigger builders; no errors either.

shiny knight theshinyknight at me.com
Thu Feb 27 06:56:01 UTC 2014

Got this weird behavior today; I have a pre-configured master; and his config is triggering the builders when a change goes in the Git repository (trough a hook and the py script, as described in the docs).

Today I decided to make a new master; so after set it up, I modified the py script for the hooks, swapping the master url with the new server.

It is peculiar that the master gets the commits; but no build is triggered. I do not understand why; it works on the other master, and both master have the exact schedulers: just one nightly scheduler at midnight (which works without problems).

Another curious thing is that I can see the same commit in all the builders; altho each builder build a different part of our application; so there is no way that a builder should be able to know about changes in another build. They are in the same repo but in different sub directory.

The logs show no error; I tried also to make a single branch scheduler, adding the builders in it (with and without the option to wait for a stable state); and yet I don't get the builders to fire up and build, no matter how long I wait after a  commit..

Where could I possibly look to find out more? The logs are clean, they get the changes in the repo and show it in the waterfall; the builders build when I run them manually, and there is just one scheduler set up, so I don't really understand why it won't trigger the builders. I am aware that this is a generic issue; so I am asking what could possibly cause this behavior, and how can I troubleshoot it.


More information about the devel mailing list