[Buildbot-devel] Python-2.5 compatibility with 0.9.0?

Dustin J. Mitchell dustin at v.igoro.us
Tue Nov 26 13:37:42 UTC 2013

At Mozilla we just standardized on 2.7.x, and it required some
hand-built Pythons for a few not-so-old platforms.  So I don't think
we're ready for that just yet.

The reasons to drop support are wanting to use language features not
available in older versions (closely related to Py3k compatibility)
and incompatibility with existing dependencies.  There aren't a whole
lot of attractive features in 2.7 that aren't in 2.6, and as Vladimir
pointed out most of our dependencies have a minimum version of 2.6.

It will definitely be a decision worth revisiting in a year or so, though!

I landed the pull request to remove 2.5 support from nine.  Hooray!


More information about the devel mailing list