[Buildbot-devel] try failing after upgrade from 0.8.1 to 0.8.3p1

A_Lawrence at DELL.com A_Lawrence at DELL.com
Fri Feb 25 16:55:49 UTC 2011

Thanks Dustin; your patch fixed it.


-----Original Message-----
From: djmitche at gmail.com [mailto:djmitche at gmail.com] On Behalf Of Dustin J. Mitchell
Sent: Thursday, February 24, 2011 6:00 PM
To: Lawrence, A
Cc: buildbot-devel at lists.sourceforge.net
Subject: Re: [Buildbot-devel] try failing after upgrade from 0.8.1 to 0.8.3p1

On Tue, Feb 22, 2011 at 3:12 PM,  <A_Lawrence at dell.com> wrote:
> It doesn’t seem to matter if there’s a buildstep using WithProperties in the
> factory used for the try build; I still see the same error if I remove that
> buildstep.
> Any suggestions?  Is anyone successfully using try in 0.8.3p1?

Try applying this patch:

diff --git a/master/buildbot/schedulers/trysched.py
index 4259b10..26a9e18 100644
--- a/master/buildbot/schedulers/trysched.py
+++ b/master/buildbot/schedulers/trysched.py
@@ -171,7 +171,8 @@ class Try_Userpass(TryBase):
         base.BaseScheduler.__init__(self, name, builderNames, properties)
         self.port = port
         self.userpass = userpass
-        self.properties = properties
+        self.properties = Properties()
+        self.properties.update(properties, "Scheduler")

     def startService(self):


More information about the devel mailing list