[Buildbot-devel] some problems with buildbot 0.8.0rc2 after upgrade from 0.7.12

Armstrong, Gareth gareth.armstrong at hp.com
Mon May 3 22:39:07 UTC 2010

Hello Folks,

just tried to open a ticket for the following on Trac but got this.

Trac detected an internal error:

SMTPSenderRefused: (452, '4.3.1 Insufficient system storage', u'"Buildbot" <buildbot-devel at lists.sourceforge.net>')

Anyway on to my observations. I just upgraded one buildbot master instance to 0.8.0rc2 from 0.7.12 and all went well (well almost).
This master is on Rhel5 with the following config.

* Buildbot: 0.8.0rc2
* Twisted: 10.0.0
* Jinja: 2.2.1
* Python: 2.4.3 (#1, Jun 11 2009, 14:09:58) [GCC 4.1.2 20080704 (Red Hat 4.1.2-44)]

1) "buildbot upgrade-master `pwd`" does not terminate and has to be killed manually. Is this meant to be?

[bbmaster at pear try]$ buildbot upgrade-master `pwd`
populating /home/bbmaster/pm/try/public_html/favicon.ico
/home/bbmaster/pm/try/public_html/robots.txt has old/modified contents
writing new contents to /home/bbmaster/pm/try/public_html/robots.txt.new
/home/bbmaster/pm/try/public_html/bg_gradient.jpg has old/modified contents
writing new contents to /home/bbmaster/pm/try/public_html/bg_gradient.jpg.new
populating /home/bbmaster/pm/try/public_html/default.css
/home/bbmaster/pm/try/master.cfg.sample has old/modified contents
overwriting it with new contents
Notice: Moving /home/bbmaster/pm/try/public_html/index.html to /home/bbmaster/pm/try/templates/root.html.
You can (and probably want to) remove it if you haven't modified this file.
migrating changes.pck to database
(408 Change objects)
moving changes.pck to changes.pck.old; delete it or keep it as a backup
upgrade complete

2) Once upgrade I started the master all looked good. This master is running several Nightly schedulers with multiple SVNPollers. The schedulers fired at the requested times however they completely ignored the Changes that should have been in the Build. I.e. the Blame list was empty when it should have had several changes. Is this a known issue. If not I will provide some more detail. The config worked prefectly in 0.7.12 and the schedulers were all defined as dicts. Any thoughts? Many thanks again in advance.

All the best,


PS I have a working buildbot.spec file for 0.8.0rc2 which I will pass to the list after rolling to 0.8.0rc3 later today.

More information about the devel mailing list