[Buildbot-devel] Buildbot, MacOS and wxPython

Jérôme Laheurte fraca7 at free.fr
Sun Jul 12 14:20:11 UTC 2009

Hello. I'm trying to set up a buildbot for Task Coach (http://www.fraca7.net:8010 
) and I'm mostly successfull except for one thing. On Mac OS X (10.4  
and 10.5 alike), the unit tests pass if I launch them by hand from a  
terminal. But when launched as a build slave, they crash with an  
"CGSResolveShmemReference : offset exceeds bounds" error message.

 From then on, they crash with the same error message even when ran by  
hand, until I reboot the slave.

Since these unit tests interact with the desktop, the slave was  
launched from a terminal (make start), so I expected them to run  
exactly as if launched by hand. I tried launching twisted with the -n  
option, same problem. I also disabled power saving and the screen  
saver, to no avail.

I don't actually know if it's a problem with buildbot, twisted, wx or  
Mac OS but I thought I'd have a better chance of finding someone  
having run into the same problem here...

So does anyone have a hint ? Google was no help, for once, nor this  
list's archives...

Jérôme Laheurte

More information about the devel mailing list