[Buildbot-devel] DirectoryUpload doesn't upload file completely, still thinks it succeeded

Sidnei da Silva sidnei.da.silva at gmail.com
Fri Jul 3 23:53:13 UTC 2009

Dustin J. Mitchell <dustin at ...> writes:
> Please do try trunk - Stefan basically rewrote it completely.  If
> you'd prefer to patch your installed version, you'll want

I am now running trunk, and found a small issue already: the tarfile is not
being closed before being removed, which is not cool on Windows. :) I tried to
report a bug but Trac won't let me in. Here's the traceback:

 File "C:\python25\lib\site-packages\twisted\ internet\defer.py", line 328, in
    self.result = callback(self.result, *args, **kw)
line 1010, in finished
exceptions.WindowsError: [Error 32] The process cannot access the file because
it is being used by another process:

Adding a simple 'self.fp.close()' before 'os.remove()' should do the trick (I'm
testing this now, but my uplink is very slow).

In other news, it seems like my original issue was actually lack of space in
'/tmp' while uploading, but somehow the master's twistd.log doesn't say
anything, just 'success'. The new version does log a proper exception about it,
so it's a win after all. FTR I'm running this master off a Nokia N810, which has
measly 512k of space in '/tmp' :) Starting the master with 'TMP' and 'TMPDIR'
set to a directory with more space seems to have solved that.

-- Sidnei

More information about the devel mailing list