[Buildbot-devel] need help using "try"

Yury Itskovich Y.Itskovich at Astronautics.com
Tue Feb 3 21:00:43 UTC 2009

I should mention, I'm using:
Buildbot version: 0.7.8
Twisted version: 8.1.0
Python 2.5.2


-----Original Message-----
From: Yury Itskovich
Sent: Tue 2/3/2009 9:13 AM
To: Marcus Lindblom
Cc: buildbot-devel at lists.sourceforge.net
Subject: RE: need help using "try"
Hi Marcus,

This is the output:

$ buildbot try --master=localhost:8031 --username="alice" --passwd="pw" --wait
using 'pb' connect method
job created
job has been delivered
contacting the status port at localhost:8031
Unhandled error in Deferred:
Traceback from remote host -- Traceback unavailable
buildbot-full: no build

from twistd.log:

2009-02-03 09:01:36-0600 [Broker,4,] <Scheduler 'testtry' at 142722988> got connection from user alice
2009-02-03 09:01:36-0600 [Broker,4,] user alice requesting build on builders ['buildbot-full']
2009-02-03 09:01:36-0600 [Broker,4,] maybeStartBuild <Builder 'buildbot-full' at 144934220>: [<buildbot.process.base.BuildRequest instance at 0x8a5f3ac>, <buildbot.process.base.BuildRequest instance at 0x8a4e64c>, <buildbot.process.base.BuildRequest instance at 0x8abc74c>, <buildbot.process.base.BuildRequest instance at 0x8ac1aec>] []
2009-02-03 09:01:36-0600 [Broker,4,] <Builder 'buildbot-full' at 144934220>: want to start build, but we don't have a remote
2009-02-03 09:01:36-0600 [Broker,5,] Peer will receive following PB traceback:
2009-02-03 09:01:36-0600 [Broker,5,] Unhandled Error
	Traceback (most recent call last):
	Failure: twisted.cred.error.UnauthorizedLogin:


from buildbot.scheduler import Scheduler
c['schedulers'] = []
c['schedulers'].append(Scheduler(name="all", branch=None,

from buildbot.scheduler import Try_Userpass
c['schedulers'].append(Try_Userpass("testtry", ["buildbot-full"], port=8031, userpass=[("alice","pw")]))

I created a local SVN repository, and when I commit a change, I get the same error in the log:

2009-02-02 14:36:01-0600 [-] SVNPoller polling
2009-02-02 14:36:01-0600 [-] SVNPoller: svnurl=file:///home/yury/test_repo, root=file:///home/yury/test_repo, so prefix=
2009-02-02 14:36:01-0600 [-] svnPoller: _process_changes 2 .. 3
2009-02-02 14:36:01-0600 [-] Adding change revision 3
2009-02-02 14:36:01-0600 [-] adding change, who yury, 1 files, rev=3, branch=None, comments sdf
2009-02-02 14:36:01-0600 [-] <Scheduler 'all' at 142679788>: change is important, adding <buildbot.changes.changes.Change instance at 0x8a591ec>
2009-02-02 14:36:01-0600 [-] <Scheduler 'all' at 142679788>: setting timer to 14:36:11
2009-02-02 14:36:01-0600 [-] SVNPoller finished polling
2009-02-02 14:36:01-0600 [-] _finished : None
2009-02-02 14:36:11-0600 [-] maybeStartBuild <Builder 'buildbot-full' at 144937836>: [<buildbot.process.base.BuildRequest instance at 0x8a5972c>] []
2009-02-02 14:36:11-0600 [-] <Builder 'buildbot-full' at 144937836>: want to start build, but we don't have a remote

I must be missing something simple in the setup/configuration that's causing this.
This is the setup for the poller and builder from master.cfg:

from buildbot.process import factory
from buildbot.steps.source import SVN
from buildbot.steps.shell import Compile
f1 = factory.BuildFactory()


b1 = {'name': "buildbot-full",
      'slavename': "testslave",
      'builddir': "full",
      'factory': f1,

c['builders'] = [b1]


-----Original Message-----
From: Marcus Lindblom [mailto:macke at yar.nu]
Sent: Tue 2/3/2009 2:19 AM
To: Yury Itskovich
Cc: public-buildbot-devel-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f at hugh.gmane.org
Subject: Re: need help using "try"

Yury Itskovich wrote:
> Changed master.cfg to say:
> try_sch = Try_Userpass("testtry", ["buildbot-full"], port=8031, 
> userpass=[("alice","pw")] )
> and in options:
> try_master = 'localhost:8031'
> Still get the same error.  Using the --master, --username, and --passwd 
> options from the command line fails as well, but with a less descriptive 
> error message.  Anyone have any input at all?  Could the problem be 
> totally unrelated to the buildmaster hostname, etc? 
> Can I use the manhole thing to get more information on what's wrong?
> Any suggestions would be really appreciated...

I don't know offhand. I know I have gotten it to work, so it's not 
totally broken. :)

What are the 'less descriptive' error messages?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://buildbot.net/pipermail/devel/attachments/20090203/9665a184/attachment.html>

More information about the devel mailing list