[Buildbot-devel] Installing buildbot on Tiger

Christopher Rasch crasch at gmail.com
Fri Nov 10 06:00:53 UTC 2006


I'm trying to install buildbot on Tiger, and I'm encountering some 
difficulties.  Here's my platform:  24 in iMac, Mac OS X 10.4.8, 2.16 
Ghz Intel Core 2 Duo, 1 GB SDRAM

I first tried to install using port

sudo port install buildbot

This appeared to successfully install buildbot and all of its 
dependencies.  However, when I ran the self-tests, I got a number of 
error messages and test failures.

Upon searching the archives, I believe most of the errors were caused 
due to the bugs described here:


So I uninstalled the buildbot port:

sudo port uninstall buildbot

And checked the latest code out of CVS as follows:
cvs -z3 
-d:pserver:anonymous at buildbot.cvs.sourceforge.net:/cvsroot/buildbot co 
-P /buildbot

Built and installed the software :
python setup.py build
sudo python setup.py install

Ran the self-tests:

PYTHONPATH=. trial buildbot.test

All of the tests passed except as attached at the bottom of this message.

I also encountered the following problems:

The buildbot executable was not installed into /usr/bin as the 
documentation suggests.   Judging from the output of the install, it 
looks like most of the supporting files went into the 
site-packages/buildbot directory:


It looks like the actual executable when in this directory:


The /System/Library/Frameworks/Python.framework/Versions/2.3/bin is not 
in my path, so this command failed:

buildbot --version

If I run it with the full pathname, I get the following error message: 

crasch2:~ crasch$ /System/Library/Frameworks/Python.framework/Versions/2.3/bin/buildbot --version
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/bin/buildbot", line 3, in ?
    from buildbot.scripts import runner
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/buildbot/scripts/runner.py", line 6, in ?
    from twisted.python import usage, util, runtime
ImportError: No module named twisted.python

Although buildbot could not find it, twisted is still installed via the port system: 

sudo port installed
The following ports are currently installed:
  py-twisted @2.4.0_0 (active)
  py-zopeinterface @3.1.0c1_0 (active)
  python24 @2.4.3_1+darwin_8 (active)

1.  How concerned should I be about the error messages below?  What 
should I do to fix them?

2.  Where would you recommend I install buildbot?  Should I delete it, 
and reinstall it with port?  Delete it, and reinstall it in /usr/local:
python setup.py install --prefix=/usr/local|

3.  If I keep the installation from CVS, how do I tell buildbot where to 
find twisted, zopeinterface, and python2.4 in the ports library? 

Thanks for any help! 

[ERROR]: buildbot.test.test_slavecommand.ShellPTY.testInterrupt1

line 899, in writeSomeData
    return os.write(self.fd, data)
exceptions.OSError: [Errno 5] Input/output error
[ERROR]: buildbot.test.test_slavecommand.ShellPTY.testTimeout

line 899, in writeSomeData
    return os.write(self.fd, data)
exceptions.OSError: [Errno 5] Input/output error
Ran 261 tests in 227.473s

FAILED (skips=27, errors=2, successes=232)

More information about the devel mailing list