[Buildbot-devel] Question on build slaves and twisted logs

Franklin, Lyndsey lyndsey.franklin at pnl.gov
Fri Jul 29 23:40:25 UTC 2005

    Here's my setup: I have a Linux computer that has my build master
and a build slave on it, and a Windows and a QNX 6.3 computer each with
a build slave on them.  The Linux and Windows build slaves are running
just fine and do everything they need to but the QNX build slave is
giving me problems.
    The more irksome of the QNX slave's problems is its twisted logs.
It generates a separate log file for every entry (i.e., the whole "Log
Opened" entry appears in twisted.log, the whole "twistd 2.0.1 (python
2.4.1) starting up" entry appears in twisted.log.1, etc).  I get about
10 of them just by starting the QNX build slave.  Whatever the cause is,
it seems to start right away before any pinging or checkouts can occur
so I don't think they have much to do with this one.  I've tried to read
through the code and find where the problems might begin but to be
honest, I'm getting nowhere slowly.  I think my problems could be in the
log rotation or in some obscure fork step but I was hoping I could save
myself some headaches by asking if any one else had seen this and
figured it out.
    The reason I know the whole entry gets its own log file is that the
QNX slave is also having troubles with the Subversion check outs.  The
trace back (along with its entry) appears in a single log file and says
that it can't find the pty module, but I've checked and I know that it's
compiled and where (I think) it should be: /usr/local/lib/python2.4/.
My Linux machine has it in an equivalent location and everything works
just fine there.  Could there be a path problem on the QNX machine?
    I haven't seen many QNX questions on this mailing list so perhaps no
one has tried anything with QNX yet.  I can also imagine that these are
somehow all problems with the QNX machine itself but I thought I'd ask
and see if anyone knew of something in buildbot that I might have
configured wrong.  Thanks in advance for any advice!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://buildbot.net/pipermail/devel/attachments/20050729/f072f1f0/attachment.html>

More information about the devel mailing list