[Buildbot-devel] process killed by signal 1

Paul Warren u3292467 at anu.edu.au
Fri Jul 8 00:44:18 UTC 2005

Brian Warner wrote:
>>The problem we have, (as you can see from the logs), is that the debian
>>buildbot is dying with a:
>>process killed by signal 1
>>program finished with exit code -1
>>Now this is very strange, becaues if I run trial manually, with the same
>>environment as buildbot is running in, all the tests run successfully
>>and I get no 'process killed' problems.
> That *is* weird. Since signal 1 is SIGHUP, my hunch is that the buildslave is
> running the test under a PTY, and the somehow the PTY is closing slightly
> early (after the child process has emitted the final test-count line, but
> before it actually terminates). It's like logging into a remote host,
> starting a process, then logging out.. the process may or may not be touched,
> depending upon how it was started (with 'nohup', with '&', depends upon the
> shell, etc). I think the shell uses SIGHUP to tell the process that its
> terminal just went away.
> These days I'm leaning away from using PTYs for child-process management, but
> that's mostly because I don't have to deal with the environment which
> prompted their use in the first place (unit tests which created several
> non-daemonized child+grandchild processes, where a test failure could leave
> those children running, so using a PTY provided a process group that made it
> easy to kill them all off at the same time, at least under solaris).
> If the problem persists, try telling the slave to not use a pty (by setting
> 'usepty=0' in the buildbot.tac file) and see if that affects it.
> let me know if that helps,
>  -Brian

Thanks, fixed that problem!

> PS: it looks like your buildbot is hitting the same problem that Nick patched
> a little while back, where a restarted buildmaster is overlapping build
> numbers with the earlier invocation, and an assert() statement is killing the
> logfile creation.
Right, I fixed that by just deleting the offending log files.  The power
was cut (after a pretty scary fire in the machine room) to my office
where my buildmaster is, so it was an unclean restart.

> PPS: you might also want to change your Trial step to use --bwverbose instead
> of --verbose, so you don't get the ANSI color escape sequences in your
> logfiles.

I finally worked out how to use the Trial factory, have the formatting
all good now.

Thanks for the great software !

Paul Warren
Information Infrastructure Services
ANU SuperComputer Facility
Leonard Huxley, Rm 338
u3292467 at anu dot edu dot au
ph: 612 51481

More information about the devel mailing list